VistaDB Support Center

Visual Studio 2015 and .NET 4.6 Support

Today Microsoft announced the RTM of Visual Studio 2015 and .NET 4.6:
Visual Studio 2015 and .NET 4.6 Available for Download


What does this mean for VistaDB?


VistaDB works with .NET 4.6


If you switch your application over to using .NET 4.6 today your existing VistaDB code will still work.  You can cheerfully deploy your applications and really nothing changes.


VistaDB Visual Studio Support Shipped in VistaDB 5.1.3


We shipped an updated version of VistaDB 5.1 with support for Visual Studio 2015 in November as version 5.1.3.   This update is free for all folks licensed for version 5.1.  Of you are running an older version of VistaDB and upgrade to Visual Studio 2015 you'll find that the VistaDB-specific application templates and designers are not available.  This includes the Database-first designer for Entity Framework 6.0.  Therefore, we recommend that folks using Entity Framework 6 or the VistaDB designers for typed datasets update to this version or later.

Login to post a comment