If you upgrade to Visual Studio 2015, the VistaDB extension is not available.  This is because each version of Visual Studio requires an extension to be specifically designed to install into it and extend it. 

We will be shipping an updated version of VistaDB 5.1 with support for Visual Studio 2015 in November. This update will be free for all folks licensed for version 5.1. Until then, if you upgrade to Visual Studio 2015 you'll find that the VistaDB-specific application templates and designers are not available. This includes the Database-first designer for Entity Framework 6.0. Therefore, we recommend that folks using Entity Framework 6 or the VistaDB designers for typed datasets wait until we ship this update to upgrade to Visual Studio 2015.

If you need this urgently, please contact support and we can provide you with a preview build of 5.1.3 which has this feature.